Contradictions

Chris Charman - 26 Feb 2009

So I've got a need to do some work in Rails. Since I've not really used it before, I decided to go through the nice tutorial at Rubyonrails.org. I'm running merrily along when:

% rake db:create
Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update --system` and try again.

Okay, fine. I try it...

% sudo gem update --system
Updating RubyGems
Nothing to update

Huh. Really?

I found this helpful tidbit about updating RubyGems on Mac OS X.

% sudo gem install rubygems-update
Successfully installed rubygems-update-1.3.1
1 gem installed
% sudo update_rubygems
Installing RubyGems 1.3.1
[... a bunch of stuff ...]
------------------------------------------------------------------------------
RubyGems installed the following executables:
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem

If gem was installed by a previous RubyGems installation, you may need to remove it by hand.

Well, that definitely looks more promising!

% gem --version
1.3.1

Sweet.

comments powered by Disqus